POJ 2505 A multiplication game

扑克投资家 2018-01-07

A multiplication game

Time Limit:1000MSMemory Limit:65536K
Total Submissions:6421Accepted:3225

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

Source

Waterloo local 2001.09.22

不难想到的博弈。
两个人可以到达的数肯定最多只有2,3,5,7这四个质因子,而之前在bzoj数字之积已经提到了<=4*10^9里
这样的数也就6000多(写了个程序算了一下),所以我们可以把这些数找出来然后连上边之后直接就是裸的博弈了(注意是要找出<n的所有乘积,等于n的话游戏已经结束了):
如果一个点*9>=n,那么它肯定是必胜状态;
否则找它的所有后继,如果有至少一个是必败状态,那么当前就是必胜状态;否则是必败状态。

POJ 2505 A multiplication game

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
#define maxn 10005
using namespace std;
ll n,tot,val;
ll num[maxn],pos[20];
ll to[maxn][20];
bool win[maxn];

inline void prework(){
    tot=0;
    for(ll i=1;i<n;i<<=1)
        for(ll j=i;j<n;j*=3ll)
            for(ll k=j;k<n;k*=5ll)
                for(ll l=k;l<n;l*=7ll) num[++tot]=l;
    sort(num+1,num+tot+1);
    
    memset(pos,0,sizeof(pos));
    memset(win,0,sizeof(win));
    
    for(int i=1;i<=tot;i++){
    //    to[i][1]=i;
        for(int j=2;j<=9;j++){
            val=num[i]*(ll)j;
            while(pos[j]<tot&&num[pos[j]]<val) pos[j]++;
            to[i][j]=(num[pos[j]]==val?pos[j]:0);
        }
    }
}

int main(){
    while(scanf("%lld",&n)==1&&n){
        prework();
        
        for(int i=tot;i;i--){
            for(int j=2;j<=9;j++) if(!to[i][j]||(to[i][j]&&!win[to[i][j]])){
                win[i]=1;
                break;
            }
        }
        
        if(win[1]) puts("Stan wins.");
        else puts("Ollie wins.");
    }
    
    return 0;
}

相关推荐